debian - Access Denied when Mapping Drive from Windows 7 to Samba Share

16
2014-04
  • Scriptonaut

    I'm at my wits end with this, I've tried connecting to my samba server with smbusr, and smbusr_RO from windows 7 by mapping a drive. It says S:\ is not accessible, access denied. I know I'm putting the correct password in, for both users. I've even tried logging in as root, still no luck.

    Here is my smb.conf file:

    http://pastebin.com/cUGEF3yi

    If you guys need more information just ask, thanks a million.

  • Answers
    Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

    Related Question

    Samba + Centos (Share not working)
  • Marcos Placona

    I've done this a few times already, but for some reason this time it's not working.

    I have a folder called ruby (root:root - 0777) on /home/placona

    I'm trying to see this folder from my WindowsXP box, but keep getting permission denied. I can see the global share though, but whenever I try clicking on the ruby share, it won't let me in.

    Here's my smb.conf settings:

    [global]
            log file = /var/log/samba/samba.%m
            guest account = nobody
            netbios name = DEVBOX
            server string = DEVBOX CENTOS
            workgroup = WORKGROUP
            encrypt passwords = yes
            security = share
            max log size = 50
    
    [ruby]
            path = /home/placona/ruby
    

    I want to be able to open this folder without using password (hence the guest account = nobody).

    I tried even with password, but never seems to work.

    Can anyone spot anything wrong with my settings?


  • Related Answers
  • WillNewby

    Samba shares need both users and settings. I'm sure you already have CentOS users, but do you also have Samba users setup?

    smbpasswd -a joe

    you can also add the following line to your share definitions

    [ruby]
    valid users = joe randi insert-samba-user-here

    Oh and make sure you reload samba via

    service smb restart

    (Note, most code taken from: http://www.cyberciti.biz/faq/adding-a-user-to-a-samba-smb-share/ )

  • Jimmy Hedman

    Try adding:

    read only = no
    

    to your [ruby] section.

  • quack quixote

    Add these to your existing settings:

    [global]
        map to guest = Bad User
    
    [ruby]
        guest ok = yes
        read only = no
    

    You've already got the guest account setting to tell Samba which account to use as the guest user; map to guest = Bad User tells Samba to automatically convert an unrecognized username to the Guest user.

    You may also want to put these in your [ruby] section (tweak the permissions as needed):

    directory mask = 0777
    create mask = 0666