BIOS Boot-Device Selection Menu Missing

17
2014-04
  • Synetech

    My BIOS used to let me press a key (F8) which I could press during the POST to have it present a list (figure 1) of all detected storage devices so that I can choose which one to boot from (also, when the key was pressed, it would show a message like F8 pressed, showing boot menu... until the POST finished).

    I have used that feature a few times since I got this motherboard (P4P800) a couple of years ago, but it seems to be missing now. Pressing Del to access the BIOS config program still works (and still shows the Entering setup... message until the POST is finished), but the other keys no longer seem to work.

    I don’t know when this behavior started because I use the boot-selection menu infrequently, but the only significant changes to the system since the last time it worked was to add some RAM to the system so that I can use dual-channel mode (and change the AGP Aperture to 4MB to maximize available RAM on a 32-bit system), and to add my old card-reader (it just plugs into a USB port on the backplane).

    I have tried changing the settings to default (through the BIOS function) but that did not fix it. I also checked the BIOS for any and all related settings without success: I tried changing the boot device and priority settings through every permutation I could, enabled/disabled the quick-boot setting and the fullscreen logo. Not surprisingly, none of these affected it since they were not changed since it last worked…

    The last step I can think of is to re-flash the BIOS (it’s already the last version) and clear the setting via the motherboard jumpers. I doubt that would work because there is no reason that it should have changed (short of some virus or gamma ray or something that somehow managed to get through the router and software and alter the BIOS of an old motherboard for some reason).

    I could find pretty much no pages where this issue is mentioned. The closest I could find was the opposite, where some people complaining that the menu is popping up and asking how to stop that.

    One page referenced the keyboard as a possible cause which reminded me that my previous keyboard was wireless so, the F-Lock function was always on, but my new one is wired, and the F-Lock key always resets to off when I turn the system on, making the function-keys behave differently. Of course I have already tried turning it before pressing F8 repeatedly, so that is not the problem. I also tried connecting a USB keyboard and a PS/2 keyboard and had the same results.

    Has anybody seen this (BIOS keys/boot-menu go missing)? Does anybody have any ideas?

    Figure 1: Boot-device selection menu

    Screenshot of boot-select menu

  • Answers
  • Synetech

    Solution

    The problem is only peripherally related to booting. It turns out that the issue is with the settings under Boot⇨Security Settings.

    What happens is that if you change the User Access Level setting from Full Access to anything else (i.e., lower), then the BIOS does not show the prompt or accept the boot-selection key.

    This seems bizarre, but has a slightly logical purpose. The rationale is likely that if you lower user access, then you also want to prevent users from booting from a different device (i.e., in schools, businesses, etc.)

    Analysis

    The problem is that AMI (and possibly other BIOS manufacturers) has done a poor job in their labeling and design:

    • The layout, labels, logic, etc. all lead a user to believe that the user-access settings specifically control the BIOS configuration program; there is no indication that it affects other matters outside the BIOS editor like the boot-menu. This assumption is strengthened by the fact that there is a setting that determines whether the BIOS asks for a password on setup or always.

    • There are no user-access settings that allow for using the boot menu but prevent changing BIOS settings.

    • This behavior is exhibited even if the ask-for-password setting is set to Setup, meaning that users do not have to enter a password to boot.

    • This behavior is exhibited even if no user password is installed at all.

    The fact that the boot-selection menu is not even mentioned in the manual (even the latest one) makes it sound like the whole thing is just a last-minute addition, an afterthought which could explain why it is was implemented poorly. Of course the manual is for this specific motherboard, and AMI (and others) provide BIOSes to multiple manufacturers for multiple models, so unless AMI added the boot-menu just before ASUS used it in this line of boards, then it is just an example of bad logic/interface design which leads to confusion.

    Summary

    Either way, I figured out how to get the boot-menu back (which is much easier than having to alter the boot order in the BIOS whenever I need to boot from something else), and hopefully anybody else who runs into this will find their way here for the solution.

  • aTotalStranger

    I agree with your "last step" idea of reflashing and clearing settings via motherboard jumpers. You may want to clear the settings first just to see if, for some odd reason, it makes a difference. That sort of behavior in BIOS does sound really wonky though.


  • Related Question

    boot - How do I reset/update my BIOS for Optiplex GX280?
  • Questioner

    So far this has been a nightmare for me, which has been frustrating me constantly. I am using Dell Optiplex GX280 with Windows XP home edition, which is running a BIOS version A04. Recently, i've rebooted the pc to find out that its not booting. It will get to the Windows boot up screen with the progress bar but only to restart to the same process again, over and over. Frustrated that I am, i've inserted the Windows recovery CD to at least either repair of reinstall the operating system to find out that was not possible. I hit F8 to have the boot options, each of the boot option that I've selected gave me an error saying: "Selected boot device is not available." Right after that, I went to the BIOS setting and did a diagnostic test, which recognized all the Boot devices onboard. Now, I cannot even repair of reinstall Windows XP, because the system is not booting from none of the boot devices.

    The surprise is when I removed the hard-drive from the computer and loaded it on into another computer successfully; that's right, there is nothing wrong with the hard drive. After that I was totally puzzled. I found a few pointers online saying that the BIOS start-up block might be corrupted itself and I might need to flash/update the BIOS. I found the detailed instruction on how to create a Boot up disk by downloading the BIOS firmware from the manufacture's website. I did exactly as instructed below:

    Download the latest version or your choose version of BIOS file for your computer or motherboard from the manufacturer’s support site. Rename the downloaded file to AMIBOOT.ROM. Copy the file to a floppy disk. Insert the floppy disk to the floppy drive. Turn on the system.

    After I did that and powered on the PC to boot from the floppy drive, it gave me this error message: "Non-System Disk or Disk Error. Replace and Strike any key when ready." I did all that, and I kept on pressing [Ctrl]+[Home] to force it, but it did not did any satisfying result.

    Desperate as I am, my next attempt is to try the instruction below. Since I want to be ready, in the event it does not work, do you have any solution that you can provide? Please keep in mind that I cannot boot from any of the devices at this moment. My only hope now is to come on with a solution that will work through the Floppy drive, since that's the only drive that affected. Thank you very much for your advice and support in advance.

    To create a Windows startup disk, insert a floppy disk into the drive of a similarly configured, working Windows XP system, launch My Computer, right-click the floppy disk icon, and select the Format command from the context menu. When you see the Format dialog box, leave all the default settings as they are and click the Start button. Once the format operation is complete, close the Format dialog box to return to My Computer, double-click the drive C icon to access the root directory, and copy the following three files to the floppy disk:

    Boot.ini NTLDR Ntdetect.com


  • Related Answers
  • Doltknuckle

    At first look, this sounded like a bad motherboard. Though usually, the gx280 fails when the capacitors blow and the system doesn't even power on. So we might be able to salvage this situation.

    The first thing I noticed was that you were making a "boot disk" not a "MS-DOS startup disk" which is what you need to use. This brings you into a super simplified OS that you use to run the flash utility provided by dell.

    You mention that you downloaded a boot ROM from the "manufactures website". Could you add the link that you used? If you went directly to the BIOS manufacture for the update instead of the OEM, you have the wrong BIOS. In many cases, the OEM (Dell in this case) modifies the files provided by the BIOS manufacture to fit their needs. While you could use a non Dell provided BIOS and get it to work, it is not recommended.

    So here is a step by step guide of what to do note (I have done this to the gx280's in my organization):

    1. Create a MS-DOS startup disk detailed here. Do this on a working XP machine.
    2. Go to dell and download the A08 (latest) driver. I have a link here.
    3. Copy the GX280A08.EXE file to the floppy.
    4. Unplug all devices except the floppy drive from the gx280. If you have a UPS, plug the system into it (sudden powerloss in the middle of a BIOS flash kills the motherboard.)
    5. Insert the floppy into the GX280 and boot from the floppy. You should get an command prompt, usually "A:>".
    6. Type GX280A08.EXE and hit enter.
    7. Follow the onscreen instructions. You'll have to hit a particular key to approve the BIOS flash.
    8. Once the program verifies that the flash was successful, exit (if able to) and shutdown the system.
    9. Plug the CD-ROM in with the windows disk in and remove the floppy.
    10. Attempt to boot to the CD-ROM.
    11. If the CD-ROM boots, plug in the hard drive and attempt to boot to it. Note: you may have to disable the ACHI mode like @Molly suggested.

    If it still doesn't work after all of this, then you defiantly have bad hardware somewhere. My personal opinion is that the GX280 is a terrible system and you can build much more powerful systems for under $400 if you are building this for personal use. If this is a business, get the system replaced, your end user will probably love the upgraded performance.

  • 8088

    when you flash the BIOS it will use the default settings.

    my 2 cents:

    Windows XP was installed in IDE mode and after the BIOS upgrade the controller setting was changed to AHCI (or vice versa), then you will see this error.

    go into the BIOS (F2) and change the SATA controller mode accordingly.

    and to boot a Dell computer from CDROM use F12 to access the boot devices menu, F8 is only for the Windows boot options menu.

  • Jared Harley

    I almost wonder if this isn't a hardware issue. Have you tried switching out the cables for the harddrives?

    If not that, the motherboard itself could be going bad.

  • Broam

    Your floppy disk isn't created as a bootable disk. You have to use the sys program in the command line (or, alternately, if your BIOS file is small, you could try using the FreeDOS boot disk. I've had luck flashing machines booting from FreeDOS; just know that it may not always work--but the flashing program will fail to start under FreeDOS, not in the middle of the flash process.)

    Surprised though--most DELL BIOS programs come with a program that makes the disk for you, sys and all. Maybe that's changed (I stopped buying Dell years ago and only have worked with 5-year-old hand-me-down boxes from friends & family.)

  • lornix

    Older machines have BIOS limitations on hard drive sizes.

    If you have a hard drive in this machine which is GREATER than ~137Gb, and the BOOT partition is larger than 137Gb, then booting will fail if the boot files (somehow) get moved somewhere on the drive past the 137Gb mark.

    Solutions are to defrag the drive to put the boot files back at the front of the partition (mydefrag is excellent for this, google it), but this doesn't help if you can't boot.

    Another requires forethought. If you install ANY version of Windows on a drive partition larger than 137GB, consider partitioning the drive into at least TWO partitions, first (boot) less than 137GB, second (or more) any size you desire.

    This is only an issue on OLDER BIOS's, as they often didn't translate CHS into logical sectors as the newer BIOS's do nowadays. Older DELL machines suffer from this issue often.

    *BEST SOLUTION * Partition Magic or similar tools could be used to shrink the boot partition down to less than 137Gb, shuffling files around as it does so. This would resolve your problem and prevent it reoccurring in the future. These are typically on bootable media themselves and would be immediately applicable to your situation.