lan - cannot connect wireless to openwrt

05
2014-04
  • George

    I am using a modem at bridge mode and WDR3600 as openwrt router. .I have a cable from modems LAN to WDRs WAN and a cable from WDR to pc. I have connection via cable. From 192.168.1.1 when I select to enable wireless ,it highlightes the Generic MAC80211 802.11bgn (radio0) but I have no connection (signal is 0% and bitrate nothing). (I am not sure what to do with radio1 device though)

    /etc/config/wireless

    config wifi-device 'radio0'
        option type 'mac80211'
        option channel '6'
        option macaddr '...'
        option hwmode '11ng'
        option htmode 'HT20'
        list ht_capab 'LDPC'
        list ht_capab 'SHORT-GI-20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'TX-STBC'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
    
    config wifi-iface
        option device 'radio0'
        option network 'wan2'
        option mode 'ap'
        option ssid 'myOpenWrt'
        option encryption 'psk2'
        option key 'mykey'
    
    config wifi-device 'radio1'
        option type 'mac80211'
        option channel '36'
        option macaddr '...'
        option hwmode '11na'
        option htmode 'HT20'
        list ht_capab 'LDPC'
        list ht_capab 'SHORT-GI-20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'TX-STBC'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option disabled '1'
    
    config wifi-iface
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'
    

    (I am not sure what mode to select also,'ap' or 'sta' )?

    /etc/config/network

    config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
    
    config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option _orig_ifname 'eth0.1 radio0.network1 radio1.network1'
        option _orig_bridge 'true'
        option ifname 'eth0.1 tap0'
    
    config interface 'wan'
        option _orig_ifname 'eth0.2'
        option _orig_bridge 'false'
        option proto 'pppoe'
        option username '...'
        option password '...'
        option ifname 'eth0.1'
    
    config interface 'wan2'
        option _orig_ifname 'eth0.2'
        option _orig_bridge 'false'
        option proto 'pppoe'
        option username '...'
        option password '...'
        option ifname 'eth0.2'
    
    config switch
        option name 'eth0'
        option reset '1'
        option enable_vlan '1'
    
    config switch_vlan
        option device 'eth0'
        option vlan '1'
        option ports '0t 2 3 4 5'
    
    config switch_vlan
        option device 'eth0'
        option vlan '2'
        option ports '0t 1'
    
  • Answers
  • George

    Ok! I had to check 'lan' network from wireless (rasdio0) settings and it works!


  • Related Question

    router - Routed AP using OpenWRT
  • Oz123

    Background

    I want to use OpenWRT in to enhance a relatively week signal in one part of the house. The FritzBox router is located far away, and must stay at the top floor. I can't use cables.

    Partial Solution

    I am following the Routed AP Guide in the OpenWRT wiki, but I can't get my clients from the lan I am setting to ping WWW. So here is what I have:

    1. Fritz!box which I am only allowed to have the WPA key to it. The box issues IP's in the range: 192.168.178.0/255 (ESSID: "FRITZ!Box")
    2. My OpenWRT router (with Atheros Chip) with Backfire (10.03.1, r29592). My router is giving DHCP with the range: 192.168.1.127.

    Observations

    Before, I followed the guide, I entered the GUI and connected the Router via Wifi->Join to the LAN network of the FRITZ!Box. The client connect to OpenWRT has the address 192.168.1.128, and can access WWW. From the OpenWrt shell I can also ping WWW.

    After Issuing the instructions in the guide, replacing the correct IP addresses where needed. I restart everything as said, and I can connect to the new WLAN established with the name TEST.
    From my single client in that WLAN with the new IP 192.168.178.229 I can now ping the Fritz!Box at 192.168.178.1 and my OpenWRT at 192.168.178.40.

    However, I can't access WWW from client (192.168.178.229) or the OpenWRT router.

    One, more observation, which might help solving my problem: I have a bridge defined (by the automatic tools, i didn't add it...).

      br-lanroot@OpenWrt:~# ifconfig 
    br-lan    Link encap:Ethernet  HWaddr 00:24:A5:D8:0E:0D  
              inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:6665 errors:0 dropped:0 overruns:0 frame:0
              TX packets:5088 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:604264 (590.1 KiB)  TX bytes:1095085 (1.0 MiB)
    
    eth0      Link encap:Ethernet  HWaddr 00:24:A5:D8:0E:0D  
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:7976 errors:0 dropped:0 overruns:91937 frame:0
              TX packets:6272 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:847585 (827.7 KiB)  TX bytes:1656757 (1.5 MiB)
              Interrupt:4 
    
    eth1      Link encap:Ethernet  HWaddr 00:24:A5:D8:0E:0E  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
              Interrupt:5 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:1102 errors:0 dropped:0 overruns:0 frame:0
              TX packets:1102 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:79550 (77.6 KiB)  TX bytes:79550 (77.6 KiB)
    
    mon.wlan0 Link encap:UNSPEC  HWaddr 00-24-A5-D8-0E-0D-00-00-00-00-00-00-00-00-00-00  
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:11079 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:32 
              RX bytes:2462537 (2.3 MiB)  TX bytes:0 (0.0 B)
    
    wlan0     Link encap:Ethernet  HWaddr 00:24:A5:D8:0E:0D  
              inet addr:192.168.178.40  Bcast:192.168.178.255  Mask:255.255.255.0
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:927 errors:0 dropped:0 overruns:0 frame:0
              TX packets:840 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:32 
              RX bytes:115706 (112.9 KiB)  TX bytes:187458 (183.0 KiB)
    

    Extras

    ### ip route default via 192.168.178.1 dev wlan0 
    192.168.1.0/24 dev eth0  proto kernel  scope link  src 192.168.1.127 
    192.168.178.0/24 dev wlan0  proto kernel  scope link  src 192.168.178.34
    

    Can't find ip route on the OpenWrt router.

    Question

    What prevents my packets from going from my new WLAN "TEST" to the old WLAN "FRITZ!Box" ?

    Thanks in advance, Oz


  • Related Answers
  • user1455509

    Packets reaching the internet router is a good first step so far. Maybe the default route is not set up either on the repeater/wifi relay or on the client or on both. Can you check what "ip route" says on the relay and on the client?