linksys - Cannot delete folders on a network drive from Windows 7

24
2014-04
  • Jernej Jerin

    I have a really strange problem. I am using Windows 7 Professional with SP1 installed. I have a My Book 500GB external hard drive connected to the network via Linksys E3000. Now in Windows 7 I am logged in as Admin. The network disk is configured in Linksys, that an admin group can r&w. Now I have added this settings to Credential Manager, where I have specified network address of disk, username and password. I have added it, because otherwise the Windows 7 would forget the username & password on restart of the system.

    Now the network disk is working without problems. I can access file, write files on it, delete files from it. The problem arises, if I want to delete folder, that contains other files or folders. Now here for some reason it displays this error:

    enter image description here

    I tried Try Again, it displays Error 0x8007045D (I/O error):

    enter image description here

    This error is supposed to happen, when there is something wrong with USB port, or USB drivers, but this drive is not accessed via USB, it is a network based disk. Also, I don't have any problems with devices connected through USB, not that it matters in this problem.

    Then I clicked Cancel. Now what is really strange about this is, that the folder has gone missing! I will be able to see it again, if I reconnect the network disk, or restart the computer. Now I really don't understand about the permission thing, becuase I am already Admin. I have looked up under network disk properties -> security, and this is want I have found:

    enter image description here

    As you can see, it seems the account Account Unknown is what controls what can be accessed. It only has Special permission allowed. So I tried to change it to allow everything (which probably would not make a diffrence, because it seems that under that Special permission falls almost everything, as I said I can do everything except delete folders, that contain other files or other folders). When I wanted to apply the Full control that I have selected it gave this error:

    enter image description here

    It seems that I cannot change this permission. So I wanted to know who exactly is behind this permission, and I got this under Advanced -> Owner:

    enter image description here

    I guess the Linksys E3000 operates this permission. But as I have said in the first paragraph, I have setted the disk to adming group under Linksys E3000 setup (192.168.1.1), which means it has full r&w access.

    Now the strangest thing about this thing: I have also another computer, that has Windows XP SP3 installed on it. I also have the network disk added to the computer. The diffrence is, that there I am also able to delete folders, that contain files or other folders. It deletes them without any error.

    Also if I connect the disk to computer with Windows 7 on it (the one that I have problem deleting folders that have other folders or files inside it), then I can delete this folders without any problem. I would like to point out, that I also tried this on my second computer (laptop), that also has Windows 7 SP1 installed, and it displays the same error, which means that there must be something with Windows 7, otherwise the Windows XP would gave the same error.

    I really don't understand why I am able to delete it from Windows XP, but not from Windows 7. The computer, that has Windows XP installed is connected through Linksys E3000 LAN via UTP cable just as is computer, that runs Windows 7. Please help me with my question and thanks for any answers!

    Edit: Adding screenshots of Local Group Policy Editor:

    First part Second part

  • Answers
  • miky

    Go to command prompt and type rd /s/q directory.

  • surfasb

    The fact that XP doesn't have these problems but WIn7/Vista do is a dead giveaway. One of the biggest network changes in Vista/7 was the introduction of SMB v2.0. Along with that, they considerably beefed up the Windows Authentication process for the NTLM.

    More than likely, the Samba server running in MyBook isn't up to date compatible with NTLMv2 and/or SMBv2. In general, Vista/7 will balk at older authentication methods that XP was ok with.

    Some of the settings you should try. Go to your 7 gpedit.msc:

    • Biggest one is check the LAN Manager Authentication Method. Vista/7 uses NTLMv2 only. XP can also use NTLMv2, but falls back to NTLM. Switch the setting to Send LM & NTLM. (the Default in XP was actually send NTML only)
    • Network Security: NTML SSP Session security: Unlikely this is the soluiton, but 7 now requires 128 bit encryption
    • Network access: Allow Anonymous SID - Enabled -Domain Member: Digitally encrypt..... (always) This was disabled under XP. XP used the "when possible" option.

    I hope some of this helps

    Try those two settinga and we can go from there

    *Edit *

    I should probably clarify where I'm going with this. Basically, we are reproducing XP's network security settings one by one on the Windows 7 machine until we see where it hiccups.

    All the way to the point where we are just authenticating as anonymous and logging on with a guest account :) It's possible that the software inside the MyBook could just be straight up incompatible with Win7's network security.

  • Daniel Stuart

    I suspect that the files on your networked drive are set as "Read Only" - The fix is pretty simple. Right click on a file or folder, click PROPERTIES, then click GENERAL, and in ATTRIBUTES un-click "Read Only" and then you should be able to delete your files (at least most of them). I had the same problem with Linksys3000, a networked hard drive and W7.

  • harrymc

    It seems to me that you are using an account on XP that has no equivalent account on Windows 7, so Windows 7 calls it "Account unknown" and assigns it some arbitrary permissions on the disk. There have been large changes in account-management going on from XP to Windows 7, so making both share the same NTFS disk is not a trivial exercise.

    In addition, the format of NTFS disks is not the same for XP and Windows 7. Windows 7 can understand the XP flavor, but XP might not fully understand NTFS formatted under Windows 7. So if you want to reformat the disk, do it preferably under XP. I would also guess that your My Book would also feel more comfortable with the XP version of NTFS.

    In theory the following steps might fix the problem :

    1. Login on XP as THE real administrator. See : Unhide the Administrator Account in Windows XP.
      (I have not tried it, but one hopes that this account is defined the same on both XP/7.)
    2. Branch the external disk directly on XP
    3. Take ownership of the root folder (see this) using "Replace owner on subcontainers and objects"
    4. Delete all other permissions except Administrator off the root folder and add Everyone with total control
    5. Propagate your changes to the whole disk using the root-folder's Properties, Advanced button, Change Permissions button, check "Include heritable permissions from this object's parent", finally OK button.

    I cannot promise that you may not sometimes in the future need to repeat again the above steps.

    Another idea is to reformat the disk as FAT32. This would be better done on Windows 7, as in Windows XP you can only format FAT32 disks up to 32 GB in size. As FAT32 doesn't store account information, all users will have access to the entire drive, regardless of their account type.

  • miky

    If you have EN windows,add this into your registry,then right button on mouse and select take ownership. after that,you can dele that file. Save folowing code as *.reg
    Take ownership:

     Windows Registry Editor Version 5.00
    
     [HKEY_CLASSES_ROOT\*\shell\runas]
     @="Take Ownership"
     "NoWorkingDirectory"=""
    
     [HKEY_CLASSES_ROOT\*\shell\runas\command]
     @="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrators:F"
     "IsolatedCommand"="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrators:F"
    
     [HKEY_CLASSES_ROOT\Directory\shell\runas]
     @="Take Ownership"
     "NoWorkingDirectory"=""
    
     [HKEY_CLASSES_ROOT\Directory\shell\runas\command]
     @="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant administrators:F /t"
     "IsolatedCommand"="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant administrators:F /t"
    

    For removing that from registry:

     Windows Registry Editor Version 5.00
    
     [-HKEY_CLASSES_ROOT\*\shell\runas]
    
     [-HKEY_CLASSES_ROOT\Directory\shell\runas]
    

    U can run cmd as well.

    first run this:

     takeown /f c:\badfile.xxx /r /d y
    

    after that run:

     icacls c:\badfile.xxx /grant administrators:F /t
    

  • Related Question

    samba - Is Windows 7 better at handling mapped network drives than Windows XP?
  • Kevin Herrera

    I am looking for justifications to upgrade my workstation from Windows XP (SP3) to Windows 7.

    Is Windows 7 better at handling mapped network drives than Windows XP?

    I keep having issues with "drive already in use" and I really suspect it's the way XP handles networked drives.

    The samba server I am mapping to is consistent and never changes.

    On occasion XP will prompt some error with the drive.

    Almost seemingly at random.


  • Related Answers
    Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.