hard drive - Can't see USB reader in Linux Mint 15

16
2014-04
  • Paul

    I'm new to Linux. I installed Mint 14 and everything was fine, my USB card reader worked straight away. I have just upgraded to Linux Mint 15 and now my SD card reader won't work – well I can't access it.

    dmesg shows:

    [11310.514867] usb 1-1: USB disconnect, device number 4
    [11316.940071] usb 1-3: new high-speed USB device number 5 using ehci-pci
    [11317.074629] usb 1-3: New USB device found, idVendor=058f, idProduct=6364
    [11317.074636] usb 1-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [11317.074640] usb 1-3: Product: Mass Storage Device
    [11317.074643] usb 1-3: Manufacturer: Generic
    [11317.074646] usb 1-3: SerialNumber: 058F63646476
    [11317.075620] scsi4 : usb-storage 1-3:1.0
    [11317.077606] hid-generic 0003:058F:6364.0005: hiddev0,hidraw2: USB HID v1.10 Device [Generic Mass Storage Device] on usb-0000:00:1d.7-3/input1
    [11318.072904] scsi 4:0:0:0: Direct-Access     Generic- SD/MMC           1.00 PQ: 0 ANSI: 0
    [11318.073508] scsi 4:0:0:1: Direct-Access     Generic- Compact Flash    1.01 PQ: 0 ANSI: 0
    [11318.074012] scsi 4:0:0:2: Direct-Access     Generic- SM/xD-Picture    1.02 PQ: 0 ANSI: 0
    [11318.074633] scsi 4:0:0:3: Direct-Access     Generic- MS/MS-Pro        1.03 PQ: 0 ANSI: 0 CCS
    [11318.078880] sd 4:0:0:0: Attached scsi generic sg1 type 0
    [11318.079153] sd 4:0:0:1: Attached scsi generic sg2 type 0
    [11318.079548] sd 4:0:0:2: Attached scsi generic sg3 type 0
    [11318.079751] sd 4:0:0:3: Attached scsi generic sg4 type 0
    [11318.080395] sd 4:0:0:0: [sdb] Attached SCSI removable disk
    [11318.084411] sd 4:0:0:1: [sdc] Attached SCSI removable disk
    [11318.087891] sd 4:0:0:2: [sdd] Attached SCSI removable disk
    [11318.089391] sd 4:0:0:3: [sde] Attached SCSI removable disk
    

    I don't know what to do next. From reading I think I need to mount it but I don't know how.

    Anyone's advice appreciated, and yes – downgrading back to 14 is an option.

  • Answers
    Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

    Related Question

    partitioning - What's up with this 64GB USB thumb drive appearing as two disks?
  • bmdhacks

    I recently purchased a 64gb usb thumb drive, but for some reason it appears as two disks on every system I've insert it in. I've tried to repartition it in Linux, Windows, and MacOS to no avail. Here's the dmesg when I insert it in a linux box:

    usb 1-6: USB disconnect, address 4
    usb 1-5: new high speed USB device using ehci_hcd and address 5
    usb 1-5: New USB device found, idVendor=1307, idProduct=0165
    usb 1-5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    usb 1-5: Product: USB Mass Storage Device
    usb 1-5: Manufacturer: USBest Technology
    usb 1-5: SerialNumber: 09090388b7b0a7
    usb 1-5: configuration #1 chosen from 1 choice
    scsi5 : SCSI emulation for USB Mass Storage devices
    usb-storage: device found at 5
    usb-storage: waiting for device to settle before scanning
    usb-storage: device scan complete
    scsi 5:0:0:0: Direct-Access                               0.00 PQ: 0 ANSI: 2
    scsi 5:0:0:1: Direct-Access                               0.00 PQ: 0 ANSI: 2
    sd 5:0:0:0: Attached scsi generic sg4 type 0
    sd 5:0:0:1: Attached scsi generic sg5 type 0
    sd 5:0:0:0: [sdc] 61440000 512-byte hardware sectors: (31.4 GB/29.2 GiB)
    sd 5:0:0:0: [sdc] Write Protect is off
    sd 5:0:0:0: [sdc] Mode Sense: 00 00 00 00
    sd 5:0:0:0: [sdc] Assuming drive cache: write through
    sd 5:0:0:1: [sdd] 63995904 512-byte hardware sectors: (32.7 GB/30.5 GiB)
    sd 5:0:0:1: [sdd] Write Protect is off
    sd 5:0:0:1: [sdd] Mode Sense: 00 00 00 00
    sd 5:0:0:1: [sdd] Assuming drive cache: write through
    sd 5:0:0:0: [sdc] Assuming drive cache: write through
     sdc:
    sd 5:0:0:0: [sdc] Attached SCSI removable disk
    sd 5:0:0:1: [sdd] Assuming drive cache: write through
     sdd:
    sd 5:0:0:1: [sdd] Attached SCSI removable disk
    

    Can somebody tell me how I can re-partition this thing to appear as a single drive? I've had no luck with any of the partition utilities on any OS because this drive doesn't appear as one disk with two partitions, but two physical disks.

    UPDATE
    The drive is a Centon ElitePlus. I'm beginning to think that something is physically wrong with this drive. Can anyone confirm?


  • Related Answers
  • Marcin

    Here is the explanation directly from Centon:

    Question: I recently purchased one of your 64GB DataStick flash drives, and I was surprised to find that the 64GB device was formatted with two partitions. Why is this? Can it be re-configured?

    Answer: Due to a limitation in Windows 2000/XP/2003 computers, drive volumes cannot be formatted in capacities larger than 32GB using the FAT32 file system. As a result, to ensure the drive can be recognized by the most number of computer systems, our 64GB drive is partitioned into two 32GB volumes. The Windows formatted capacity is roughly around 30GB.

    When the 64GB drive is connected to your Windows computer, it will be assigned two drive letters.

    The drive cannot be reconfigured into a single 64GB partion. The partition on these drives is hardcoded into the USB-to-flash controller chip.

    So no, your drive is not faulty. They decided that the best thing for you, the consumer, is to actually use two seperate drives. I would be pissed if I ordered a USB drive and realized that the manufacturer created this restriction without any mention on the product description page.

  • quack quixote

    It doesn't appear to be two partitions, it appears as two separate drives. If it were two partitions on a single drive, you'd see device names like sdc1 and sdc2.

    It's likely the drive is implemented as two physical drives at the hardware layer, and depends on a special driver to allow the OS to see it as a single drive. It may also be a chipset limitation (in whatever chipset is used in the thumbdrive hardware).

    Either way, it doesn't seem likely that you'll be able to force it to be seen as a single drive. If you require this functionality, return the device for a refund and buy a different device.