windows 7 - Computer keep crashing when starting 3D applications / games

16
2014-04
  • Mr.X

    I've noticed this serious problem days ago when I was playing Star Trek Online. When playing, I switched out of the game to check IRC msgs. When I switched back, I only saw the game interface less than a second then my system crashes (no sound, monitor reports "No Signal" and numlock key failed too). I have to reset my computer. And within a day I can't even see STO's interface; the computer crash instantly after loading screens. Then when I try to use 3D window switch of Windows 7, same thing happens sometimes. I then tried other 3D games like TrackMania, and I could only see the rotating globe (3D) for a fraction of second then my computer crashed again. It seems that any 3D rendering would crash my system.

    The strange thing is I could run some other applications which use GPU at 100% but with no 3D renders, like miners of cryptocurrency.

    I'm not overclocking my system.
    Checked CPU and GPU's temperature and both are fine.
    Tried minimal system, no luck.
    Tried many drivers from 275.33 to 290.xx beta, no luck. I was using 285 driver without any problems. And now I'm at 285 driver too.

    System spec:
    CPU: AMD Phenom II X4 940
    Memory: Kingston 3 x 1GB
    MB: Gigabyte MA78GM-US2H
    GPU: Galaxy GeForce GTS250

    Any help is appreciated, it's driving me crazy these days.

  • Answers
  • Mr.X

    Well, I've changed a PSU and all problems solved. Looks like my PSU is too old to drive my computer.

  • Edin

    It is not really an answer, but try adjusting some settings in the NVIDIA Control Panel that you think might cause the problem. Make also sure you have the latest Windows updates and the latest drivers (you can find a very large driver pack at http://drp.su/).


  • Related Question

    crash - Constant crashes in windows 7 64bit when playing games
  • z -

    I've tried everything I can possibly think of in trying to fix this problem and I'm totally out of ideas, so any help would be appreciated:

    The problem: whenever I fire up a game, it works for a short while with no problems and then it would crash. Either its a hard crash, forcing me to reboot, or windows would report that the display driver has stopped working and recovered. Here is a list of things I've already tried:

    1. Drivers - tried the latest drivers (catalyst 9.12) as well as the stock drivers that came with the video card. Also have the latest BIOS/chipset
    2. Memtest - Ran Memtest86+ overnight, had no problems, the windows diagnostic tool also does not find any problems.
    3. Overheating - Video card/cpu temperatures are well below peak (42 and 31 Celsius receptively)
    4. PSU Voltage - CPUID shows that the voltage levels are all above what they should be. The PSU itself is only roughly 16 months old and is a good model.
    5. HDD - No errors when checked
    6. GPU - Brand new (replaced previous card since I thought it was the problem, apparently not)
    7. Overclocking - Everything is at stock levels, memory voltage is set to manufacturer's standard

    Specs:

    • Motherboard: ASUS P5Q Pro
    • CPU: Core 2 Duo E8400 3.0 ghz
    • OS: Windows 7 home premium 64 bit
    • Memory: Mushkin Enhanced 4GB DDR2
    • GPU: Sapphire HD 5850 1GB
    • PSU: SeaSonic M12 600W ATX12V
    • DirectX: DX11

    Event Viewer after a crash always has these logged:

    A fatal hardware error has occurred.

    Reported by component: Processor Core Error Source: Machine Check Exception Error Type: Bus/Interconnect Error Processor ID: 1

    The details view of this entry contains further information.

    A fatal hardware error has occurred.

    Reported by component: Processor Core Error Source: Machine Check Exception Error Type: Bus/Interconnect Error Processor ID: 0

    The details view of this entry contains further information.

    A previous card that I had (4850x2) also had these errors, so I changed video cards, but the same thing is happening.


  • Related Answers
  • Kythos

    A few things come to mind with the errors you've posted, the cpu may not be seated properly causing issues under full load, or windows 7 is having issues with power management because a new feature is cpu core parking.

    It's unlikely a problem with the core parking but just to be sure you can go into the power options and set everything to the maximums, (not very green but it could get the job done).

    You can also re-seat the cpu, make sure you have some thermal grease on hand if you wish to go that route.

    Short of that I would recommend running a bios update which can be obtained here

    I included the afudos utility but you should be able to just copy the file to a usb stick and use the asus easy update from the bios itself.

    The latest bios is version 2102

    Edit:

    I just did some further research and found 2 people that ending up correcting their issues. One removed the x-fi pci sound card and the second disabled the on-board nic through the bios and added a usb based net card. Both people had the same error log issues and bsod problem, unfortunately it looks like a matter of trial and error to discover the culprit.

    Best of luck!

  • William Hilsum

    I know you said you checked, however when ever I have dealt with a problem like this, 90% of the time, it is a faulty PSU or graphics driver. Lastly, it can be a driver combination - for example some other dodgy hardware with a rubbish uncertified driver.

    600W is high for a single GPU system, but still, it may be worth swapping it just to test.