ubuntu - HDD bad sectors with OS

24
2014-04
  • Michael Z

    I wonder is that possible for OS to make bad sectors on Hard Drive?

    Preface:

    I have bought new HDD on 1Tb WB Caviar Black. I have installed new OS on ext4 partition Ubuntu 12.04.1 LTS. After few days S.M.A.R.T. of the Ubuntu's Disk Utility show that my hard has bad sectors! I have checked on S.M.A.R.T. immediately after installing OS - all was OK. During new OS working I have noticed some strange with HDD - all OS was freezed from 20 sec to 1 min and I have heard like HDD's engine restarting. At the dmes I have found something like this:

    [40085.407947] ata1.00: device reported invalid CHS sector 0
    
  • Answers
  • bill harder

    My experience with bad hard drives goes back into the late 1990's. You would do best to get the bootable version of Data Lifeguard Diagnostic, available here:

    http://support.wdc.com/product/download.asp?groupid=613&sid=30&lang=en

    You will find the basic info on how to create the needed CD. Boot from it and check your disk with the 'Quick Test' and if it passes that, run the 'Extended Test'. If it fails either test, you should start the RMA process with WDC.com here:

    http://support.wdc.com/warranty/index.asp?wdc_lang=en

    I suspect your drive is toast as the error message indicates the literal boot sector has failed.

    Good luck.


  • Related Question

    Massive number of bad sectors on a hard drive?
  • Chad Birch

    I just added a new hard drive to my PC, and have been seeing some strange behavior with it. I'm wondering if they're symptoms of a problem, or if I'm just hitting some glitches for some reason. I should mention that the drive is meant to be for backup, so I'm not concerned with the data on it at the moment. (I'm aware this isn't a "proper" backup solution, I have others for my important stuff, this is just to protect from drive failure).

    Anyway, I installed the drive, did a full format (took ~5 hours for a 2TB drive), and then started copying various data to it. After about 1TB had been copied, I happened to open My Computer, and noticed that the drive only had 10 GB of free space left on it, when I expected something in the 800-900 GB range. After checking various things to confirm that only 1TB should have been used, I ran chkdsk /R on it, and it came up with 880 GB of bad sectors.

    That just seems ridiculous to me, whenever I've seen bad sectors in the past, it's been a very small number. I've reformatted the drive (just a quick format this time), did a sector scan again (which reported no problems - huh?), and am currently copying to it again to see if the same thing happens. Just thought I'd ask for advice in the meantime, was that an indicator of massive problems with this drive, or could it have been some sort of glitch? Any other tools I should run on it to check?

    Windows XP x64 if it matters, thanks.


  • Related Answers
  • Psychoholic

    You should be able to find a drive fitness test from the manufacturer, which you could possibly use any reported error codes to claim warranty replacement.

  • TweakFix

    You should find the manufacturer disk tool, and see if there is something to format it. If still doesn't work, call them and ask if you can have another hard drive giving back yours.

  • OneOfOne

    I had that issue before, it was because of PCIe over-clocking the bios, turning that off automagicly fixed the problem.