windows 7 - How do I resolve the error message "USB Device Not Recognized"?

21
2014-04
  • user626528

    I'm getting this message, when I plugin a new USB device such as 3G modem or a mouse (into any port).

    The error message USB Device Not Recognized

    When I reboot leaving it in the same port, all works OK.

    If I unplug it and plug it in again, I'm getting the same message again, the device doesn't work and Windows hangs when I try to reboot or shutdown.
    I have a freshly installed Windows 7 (the same edition) on a secondary disk, and there is no such problem there.

    Any ideas, how to solve this problem without a complete reinstall of the system?

  • Answers
  • user1872852

    I solved a similar problem. My USB system had become very ill: although existing drivers would work fine, as soon as I moved any USB device to another port or installed a new device or tried, horror, to reinstall a device, Windows would refuse with "USB device not recognized". Within a couple of hours, my system was reachable by Remote Desktop only -- no USB at all worked.

    The solution in my case was:

    In that previous version of the log, I looked for the string "usb.inf". This allowed me to figure out that it was originally copied into C:\Windows\inf from:

     C:\Windows\System32\DriverStore\FileRepository\usb.inf_amd64_neutral_153b489118ee37b8
    

    This is of course system dependent. I copied both usb.inf and usb.pnf from there to C:\Windows\inf.

    That's all it took in my case.

  • goblinbox

    These are the options listed at Microsoft for the issue of USB ports made non-responsive by removing or connecting USB devices:

    1: Use Device Manager to scan for hardware changes

    2: Restart the computer

    3: Disable and re-enable the USB controller.

    Since rebooting every time you want to connect or disconnect a USB device seems like a lame solution, I'd probably try reinstalling the USB controllers:

    First, disconnect all USB devices, even your USB mouse. Then:

    1. Press "Ctrl + Esc" to open the Start Menu.
    2. Type Device Manager in the Search bar and press "Enter". Click Continue if necessary.
    3. In Device Manger, press Tab and use "Up" and "Down" to move the highlight to "Universal Serial Bus Controllers".
    4. Press "Right" and expand it.
    5. Press "Down" to move to the first item and press "Delete" to remove it.
    6. Repeat the step 5 and uninstall all items under "Universal Serial Bus Controllers".
    7. Reboot.
  • harrymc

    I would first suggest to compare in Device Manager the USB driver on both versions of Windows 7, the "bad" and the "clean". If they are not the same, this can explain the difference.

    Secondly, I would suggest booting the "bad" version in Safe mode. If the problem now disappears, then the cause is some installed product. Use Autoruns to turn off stuff in bunches and rebooting until you find the guilty product.

    [EDIT]

    As you have said that Device Manager hangs forever, your computer really seems to be in a bad shape.

    The only solution to avoid complete re-installation may be to refresh Windows by doing Startup Repair in Windows 7. This will only refresh Windows and leave alone all installed applications and their settings. You will need a Windows boot DVD of the same service-pack level as your installed system.

    If your Windows installation is too messed-up so that Startup Repair fails, you will need to reinstall Windows from scratch, recommended with a reformat of the hard disk. So ensure you have backups of all your data, and installation media for all your products including serials. On some computers you receive a boot CD that allows you to restore the system to its state as when bought.

  • Synetech

    Did they used to work? If not, then perhaps you have a bad USB hub/controller. If they did, then unless there was a short-circuit or something to damage the hub/controller, it should be possible to fix it.

    I have seen this with a few different kinds of devices. In most cases, there was nothing actually wrong with the device. (Which makes me feel really bad about spending $27CAD to ship my QX3 back to Intel in the USA in exchange for a check for $24CAD. >:-|)

    There’s a few things to try before assuming the device is at fault. You said the problem is not device-specific, so the first two options are more likely to help unless you somehow have a bunch of bad USB devices.

    1. Ensure that the cables are all correctly connected. Sometimes the cables (including the ones that connect from the ports on the front or back of the case to the motherboard) can come loose a bit, thus disrupting the connection.

    2. Clean the pins. The metal pins on the USB connector (on both the device/cable and the port) can accumulate a patina (especially in humid conditions), which disrupts the signal. Use a cotton swab with water/soap/alcohol or something to clean them off, thus restoring their electrical connection. I usually just resort to lightly scrubbing them with a cardboard Emory board.

    3. Open a command-prompt (cmd.exe), type set devmgr_show_nonpresent_devices=1 followed by devmgmt.msc. In the Device Manager, select View->Show hidden devices. Now find the device that is giving you problems, right-click it and select Uninstall. Disconnect the device, reboot, and connect it when Windows has completely loaded.

    4. Run Windows Update to see if it can detect the device and/or if there is a newer driver available.

  • ZaB

    Some USB devices are not compatible with USB power management in some operating systems. There is tickmark in USB hub properties for that.


  • Related Question

    windows xp - Why do I get "USB device not recognized"?
  • Kev

    I have an old Dell Dimension 4600 running Windows XP Home Edition Version 2002 Service Pack 3.

    When I attach my USB flash disk, XP recognises the USB device and I can browse, read and write files just fine, so it proves that the onboard USB interfaces are working.

    I also have a Three Ireland Huawei E1550 3G USB mobile broadband device. When I plug this into the PC, XP sees the device and then reports "USB device not recognized".

    The 3G stick has a data drive on it which is used to store the drivers for the 3G modem. Normally what happens is that the data drive is recognised and because there's an AutoRun.inf this is launched so that the modem drivers are installed.

    I've installed the latest chipset drivers from Dell for the machine (which include the USB drivers).

    I also copied the 3G drivers off of the datacard part of the modem (using another pc) and installed these manually, but the 3G stick still isn't recognised.

    I've read that the USB may not have enough power to drive the 3G stick, but the PC doesn't seem that old (built 2003). Could the built in USB interfaces be too old to support this device?

    Does anyone have any ideas?

    Update:

    Thanks for all the answers. It looks like the USB controller is USB v1 and doesn't know how to talk to the 3G stick. I'm going to get the user to buy a 3G router such as the Dovado UMR which will get us around this problem.


  • Related Answers
  • quack quixote

    It's possible the Dell only has USB 1, not USB 2, controllers onboard. Device Manager can tell you if you have a USB 2.0 controller. A power issue is also possible.

    Some older systems' front USB ports were only USB1 capable, while the back ports were USB2, so you could try other ports on your system. (I've also seen ports go bad, so trying a different port is a good idea from that standpoint as well.)

    If that doesn't work, and if you can verify the device works (in another computer), I'd try springing for a cheap PCI USB2 controller card. It's bound to be a newer controller than what you've got, and might allow the device to be recognized.

    For testing purposes, be sure to plug the device straight into the port -- if it came with a cable use that, or another high-quality cable, but don't use any extension cables since these could be causing problems.

  • Ben S

    Typically a "USB device not recognized" error means that the drivers have not been installed properly.

    Windows should give you the option to look for the drivers along with the error. Have you tried installing the drivers through the guided Windows install?

    If you look at your Device Manager, do you have an icon with a yellow exclamation?

    If so, try installing the drivers manually from the Device Manager.

    If you want to determine if your computer has USB 2.0 support check under "Universal Serial Bus controllers" in the Device Manager. If you see an "Enhanced Host Controller" you should have USB 2.0 support on at least one USB port.

  • Xavierjazz

    I had a similar problem with an older computer. The answer I got at that time was the old I computer could not recognize the newer USB device.

    I'm not a tech, so I may not be right, but that's what I was told.