usb flash drive - How to fix corrupted filesystem (shows as RAW) in USB device?

23
2014-04
  • Erico Yan

    I would like to ask if you know how to fix a corrupted USB? I've tried the diskpart command but it didn't work. The media is write protected.

    Do you have any idea that is much better? I need to fix it because I have important files in my flash drive. I really need to retrieve it.

    I saw that the file system is seen as RAW and is unaccessible. I tried error checking, but it requires you to format it. I tried data recovery software but all files come out corrupted. My USB is Imation 4GB. Any suggestions?

  • Answers
  • Oliver Salzburg

    I encountered the same issue just a few minutes ago. My USB flash drive was working fine at home then suddenly it was not recognized by any computers in the office. When attempting to access it, I always get the prompt to reformat.

    To resolve the issue, I click "Yes" on the do you want to format prompt then closed the next window (I did not click on the START button to start the format process). Received an error stating that Windows cannot format the drive. Unplugged the drive from the USB port then plugged it again.

  • JohnecHaber

    iCare Data Recovery free edition helped me restore lost photos from RAW sd card when it shows RAW and has not formatted error alter. I restored almost 95% of photos with this freeware.

    TestDisk is the next step if you have already restored data from raw drive. If you do not want to try testdisk since it lacks GUI, you can use Windows format to get the drive format to normal file system like NTFS or fat.

  • Silver Quettier

    diskpart is, in my experience, unreliable sometimes. It would show some filesystems as RAW when actually they are just not recognized, either because diskpart cannot do it, or because it didn't work, for some reason.

    I suggets trying GParted. You can get it as a live-CD (or live-USB) and see if it detects your USB filesystem better.

  • Breakthrough

    You can try TestDisk (free, cross-platform, and open source) - it works on almost all drives on a system, regardless of whether or not the drive is internal or external. You can use TestDisk to rewrite any partition tables found on the drive - it can even find corrupted or missing partitions and then repair the partition table.

    Alternatively, you can also use TestDisk to simply recover the files without repairing the partition table (if you just want to format and start from scratch). TestDisk can also overwrite/recover the MBR or boot sector if that's corrupted as well. I've had success using it to copy files off of corrupted partitons/drives.

  • Community

    On Windows, I just tried ZAR (Zero Assumption Recovery) with its free "Image Recovery" function.

    All my files have been recovered, even those deleted.

    It help very much but some files can't be recovered That's what I discovered when i use demo version

  • DeemV

    GParted is one of my favorites....Found as an iso itseld, also part of the Parted Magic cd...

    Disk Genius has also worked for me in the past for somewhat corrypt partion tables (fixed disks and usb flash drives).

  • Sampo Sarrala

    Most probably your USB device's memory unit is broken or there is problem in connection between flash memory controller IC and flash memory IC.

    Operating system recognizes it as USB memory unit. This means that USB interface IC (memory controller) is working. However, operating system does not get any information about USB device's memory (capacity, partitions, any bits from flash memory).

    One thing you could do is taking apart you USB device and try to examine if there is any burn marks (usually small grey or white dots/circles in IC surface). Also look for bad copper wires and for bad connections between wires and components.

    If memory IC (usually biggest IC in board) in board looks okay you could try to resolder it or change it to another board. Look from google about soldering surface mounted ICs if you want to try it.

  • slhck

    Try chkdsk (from within a Windows system).

    Open a command prompt with administrative rights and type: chkdsk p:\ /F where p stands for the according volume letter. /F stands for the option to repair found errors.

  • slm

    I have the same problems and have tried so many methods but finally this one is working. Use this software to low-level format the USB and it will remove write-protected.

    It's called, "HDD LLF Low Level Format Tool", and the main website is here.

    Screenshot

    ss of tool

    It's free for personal use (speed is capped at 180 GB per hour which is 50 MB/s).


  • Related Question

    windows - Do not get 'Safely remove' option in Tray for USB storage devices
  • darthvader

    I had done some tweaks in service settings (Disabled some as I thought it is not needed). Now, I am not getting the option to safely remove mass storage device when I click the icon on the system tray. I tried enabling some of the services, but it didn't help. Moreover I'm not very sure if this anomaly is because of my changes in services.

    Any idea how to make those 'safely remove' options appear when I click the USB icon on the tray. Right now nothing is happening when I click.


  • Related Answers
  • nik

    I have stopped depending on that tray icon.
    The RemoveDrive tool is very good and
    manages to Safely Remove the removable drives many times after that icon declares failure.

    Suggest reading up the notes on the RemoveDrive page
    (and several other pages from the same place)
    to build your confidence on that tool.
    Then, use it if you like it.

    I typically keep a shortcut as shown here on the desktop as an immediate fall-back.

    C:\some\path\RemoveDrive.exe U:\ -i -b
    

    You can do that from the command line if your drive letter keeps changing.

  • Stewart Coon

    Your device might be optimized for quick removal. That is, the write cache may be disabled. If so there is no need to turn the device off before removal.

    In "My Computer" right click on the device and get "properties". Click the "Hardware" tab. Highlight the device (again) and click the "properties" button.

  • Axxmasterr

    Have you tried this procedure?

    Right-click the Start button, select Properties, Taskbar tab,
    Customize... button. Find the Safely Remove Hardware icon and select
    either Hide when inactive, Always show, but not Always hide.
    
  • Alvaro jose varela

    Try this:

    Check if you have installed libusb-win32, possibly this is the problem, uninstall it and tell us.

    Ps: this program may not appear in Add or Remove Programs, so look in the Start menu, if not find it, do not discard yet, in "run" put "install-filer -u" without quotes (You must run as administrator), if execute, ok, if windows can not find the related application probably is not installed, in which case i don't know what is causing the problem.

  • rpr

    I had this problem on a Windows XP Pro. SP3 machine. It was fixed by restoring the system to the state a few days back in System Restore.