networking - Internet connection under Windows Vista stops working until reboot

20
2014-04
  • Questioner

    I have a fairly clean Vista Home Premium SP1 install on my desktop. There aren't many applications installed. My Internet connection always seems to stop working after web surfing for a while - sometimes 5 minutes, sometimes half an hour. (It doesn't matter whether I'm in Internet Explorer, Firefox, or Opera.) Nothing restores the connection other than a reboot, which I have been doing at least once a day.

    All other machines on my network are Windows XP, and they all work fine even when this Vista Internet connection stops working. Also, file shares to and from the Vista machine work okay even when I can't get out to the Internet.

    Things I tried:

    • Pinged various websites
    • ipconfig /release /renew, etc....
    • Rebooted router (Belkin - Yeah, I know it's crappy)
    • Rebooted cable modem (TimeWarner)
    • Disabled AVG antivirus and ZoneAlarm firewall
    • Uninstalled AVG/ZoneAlarm
    • Did a spyware scan with several programs - CLEAN!

    Also, I should point out that this machine has been working fine for the year or so that I've had it. These problems have started in the past month or so, although I can't remember anything I did that would have caused any issues. My System Restore points somehow got lost, so I can't do a System Restore.

    How do I fix this problem?

    Also, I tried using OpenDNS and am getting the same results if it makes a difference.

    I am fairly knowledgeable with both Windows and networking, but this one's got me scratching my head!

  • Answers
  • Seasoned Advice (cooking)

    From a command prompt run:

    netsh winsock reset
    

    That will reload the TCP/IP suite for Windows and can correct some issues.

    If you are using a USB adapter, whether wireless or wired, go into Device Manager and turn off the ability for Windows to shut down the device to save power. You may have to do this on the root hub and controller that match your device.


  • Related Question

    networking - Windows Vista HTTP requests stop working
  • Al E.

    (This seems similar to an issue in "Vista Internet connection stops working until reboot" but has quite a few differences, so I'm posting it separately.)

    I have Windows Vista Home Premium.

    With alarming regularity, any and all http requests simply die. I can't find any rhyme or reason for it. It can happen 20 minutes after I start my browsing session, or two hours.

    My network connection does not go down, and no other protocols seem to be affected. (I can connect to WoW, can use POP and IMAP, DropBox continues to update files, etc.) I can still ping website addresses, but the browser simply refuses to connect.

    More unusually, it kills it for all browsers. If I'm using Firefox and it dies, then start up Chrome, Safari, or IE, none of them can load any pages either. The loading indicator just "spins" forever. AJAX HTTP calls are similarly affected. (Gmail doesn't update while I'm in this state, for instance.) Only a restart has been effective in clearing it.

    I'm connecting through a Linksys router, but none of the other PCs (Win XP and Linux) on my network are experiencing this issue. Only the Windows Vista machine is so affected.

    I'm hanging on for Windows 7, but am afraid that it won't fix the issue. I am religious about keeping the OS and software up-to-date with patches.

    How can I fix this? What should I be looking at?


  • Related Answers
  • ephilip

    I would guess that it's probably your anti-virus software or firewall. As wil said, you should also check your proxy settings. This may be strange, but I've noticed that the StumbleUpon toolbar will make my http requests time out. I try using different browsers, and the http requests still time out. But, when I disable the StumbleUpon toolbar, then there are no more timeouts.

  • William Hilsum

    First things to take a look -

    Firewalls, Anti-virus, Anti-Malware....

    Development tools? Fiddler, or any other proxy server...

    Check your proxy settings in general.

    Personally, I would install Wfetch and see if I get any luck.

    Also, if you have any Virtualisation software, installed do you get the same problems from browsing the internet in them?

    Lastly, go in to safe mode with networking and try again and see if you still have the problem.

  • greyDrifter

    Does everything appear normal on your (wireless) connection details?

    Is your DNS pointing to a real address?

    I've had similar on Win7 that I'm trying to peg down the cause. But I believe that DNS the principle cause. I'm interested for selfish reasons on how this will play out. ... I was able to access sites over port 80 again after I disconnected and reconnected from the network, but I started out with restarts which also worked. Likewise other machines on the network are not affected.