linux - Model M Keyboard inputs incorrect characters after logging in to Fedora

20
2014-04
  • mickburkejnr

    I recently bought a 24 year old IBM Model M keyboard. From what I gather, it'd been left on a shelf for the last 5 years, so you can imagine the amount of dust dirt and crap that was on it. Before cleaning it, I plugged it in to my laptop (running Fedora 17) using a PS/2 to USB adapter. What I found was, while it still works, the keys I press don't correspond to what is displayed on the screen. So for example, when I type S on the keyboard, I get ß display on the screen instead. At the time, I put this down to the adapter not working properly.

    Since then, I stripped the keys off the keyboard and cleaned the whole thing. It looks like it's just come out of a box! I then plugged it in to my computer (also running Fedora 17) via a standard PS/2 plug. The computer loaded up to the login screen, and I typed in my password. Pressed enter, and I logged straight in to my machine.

    At this point, I opened up a text editor and started typing some stuff. To my horror, the keystrokes I was entering weren't coming up as intended. What came up instead were characters that would map to the pressed key but only under a different keyboard language setting.

    I opened up a program to see what keyboard language had been selected, and the correct one for the keyboard was selected (which is UK in my case). I opened up a window that would show what characters mapped to what keys, and I pressed every single key on the keyboard, and every corresponding block representing each key lit up. I went back to the text editor to try again, but I was still getting these random characters. Whats more is that the backspace key would not work, although in the other utility it would flash when pressed.

    What I know is that at the login screen the keyboard must have entered the correct characters, otherwise I wouldn't have been able to log in. Further more, keys that don't respond while using a text editor as sending signals to the computer, as illustrated in that keyboard utility. The question is why random characters are displayed when they really shouldn't be? Would this be a hardware fault or a software issue?

  • Answers
    Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

    Related Question

    Keyboard sends "tab" characters after each key
  • Sylverdrag

    I have had something really weird happen today:

    While typing, all of a sudden, almost each key of the keyboard was sending a tab after the key's own character, or deleting several characters or ...

    For instance, I would type "a" and the screen would show "a ". Inside dialogs, any key would result in shifting focus to the next control (just as if I had pressed the tab key).

    I tried an other keyboard layout, same problem. I checked to see if the tab key was somehow stuck. It wasn't.

    I updated the virus definitions of Microsoft Essentials and ran a scan which returned clean. I rebooted the computer, and the problem remained. Eventually, I closed the lid of the laptop and took it over to the shop. And of course, as soon as I got there, everything was working perfectly fine.

    As of right now, it seems to be working, but since I haven't done anything that should "logically" solve the problem, I assume it can happen again.

    Any idea what the problem could be and how to solve it?

    There have been no major changes to the system recently (except for the installation of a brand new USB 3G dongle from a reputable phone company, and everything worked fine afterwards).

    I am running Windows 7 HP 64b.


    Edit: The problem seems to be a hardware problem. I have tried booting in the Linux partition and the problem persists.

    I plugged in an external keyboard which seems to work fine so the problem definitely looks like a hardware issue.


  • Related Answers
  • Will

    I would try to narrow it down to find out if it is a hardware or a software issue first - a good way to do this would be to plug in a different keyboard and see if it makes any difference.

    If you find it's a software issue, then try closing all of your applications and as many processes as possible, and see if the problem still occurs when you're just using Notepad and nothing else.