Permission denied when using mv in Windows 7 Cygwin

18
2014-04
  • Michael Butler

    I have Cygwin installed on Windows 7 in a windows domain sign-on environment. I can run most typical commands without issue, but I cannot for the life of me use the "mv" command to move or rename files, regardless of the file or directory.

    I can copy and create files without issue.

    ┌─[12:27:57]─[mbutl2@MYHOSTNAME]
    └──> tmp $ >> pwd
    /tmp
    ┌─[12:27:58]─[mbutl2@MYHOSTNAME]
    └──> tmp $ >> touch test.txt
    ┌─[12:28:02]─[mbutl2@MYHOSTNAME]
    └──> tmp $ >> mv test.txt hello
    -bash: /usr/bin/mv: Permission denied
    

    I have already tried running Cygwin terminal as Administrator and the problem is the same.

    I'm open to workarounds, such as trying another exe for moving files and redirecting the mv command to it. Moving files works in the Windows Command Prompt.

    UPDATE: It appears that there may be a security restriction on my laptop that either prevents accessing/copying/executing the "mv.exe" program by its name or by its heuristics. Still willing to accept workarounds that replace the mv command as mentioned above.

    UPDATE 2: Screenshots in windows command line and when I open mv.exe in Windows.

    windows command prompt

    enter image description here

    UPDATE 3: output of file command:

    ┌─[12:36:09]─[mbutl2@MYHOSTNAME]
    └──> ~ $ >> file /usr/bin/mv
    /usr/bin/mv: writable, executable, regular file, no read permission
    ┌─[12:36:15]─[mbutl2@MYHOSTNAME]
    └──> ~ $ >> chmod 777 /usr/bin/mv
    chmod: changing permissions of `/usr/bin/mv': Permission denied
    ┌─[✗]─[12:36:29]─[mbutl2@MYHOSTNAME]
    └──> ~ $ >> mv
    -bash: /usr/bin/mv: Permission denied
    ┌─[✗]─[12:36:35]─[mbutl2@MYHOSTNAME]
    └──> ~ $ >>
    

    ldd also reports permission denied.

  • Answers
  • Tiago Ƈ.
    • See if the file has been blocked by Windows.

      Check the properties of the file, there may be a note saying This file came from another computer and might be blocked to help protect this computer To check for and unblock the file, follow these steps: Right-click the blocked file and then click Properties. In the General tab, click Unblock if the option is available.

    • Check to see if your antivirus is blocking the file.

      You can check to see if your antivirus software is blocking a file by temporarily disabling it, and then trying to open the file.


    Update:

    1. Right-click the file or folder, and then click Properties.
    2. Click the Security tab.
    3. Under Group or user names click your name to see the permissions you have.
    4. Click Edit, then check the check boxes for the permissions that you need and then click OK.

    Result:

    enter image description here


    Update 2:

    Try this:

    • Right click, select Properties.
    • Click the Security tab.
    • Click Advanced.
    • Click the Owner tab.
    • Change owner to yourself.
    • Click Edit.
    • Check Replace owner on subcontainers and objects.
    • Click OK.
  • Michael Butler

    The workaround was to re-download Cygwin's mv.exe utility, saving it as a different name like mvvv.exe (before actually downloading it, since I don't have access to rename mv.exe). Then, I set up a symbolic link to point mv to mvvv.exe so I can use it normally.

  • harrymc

    Just in case that something went wrong on your disk with mv.exe, I would try to :

    • uninstall Cygwin
    • chkdsk
    • verify that mv.exe was deleted with its entire folder
    • reinstall Cygwin

    [EDIT]

    You say that your antivirus is McAfee, which in my opinion is one of the most problematic of all antivirus products.

    I would suggest to disable real-time protection in McAfee to see if the problem goes away. If it does, my own recommendation is to uninstall McAfee and install some other less-intrusive antivirus product.


  • Related Question

    Permission denied when running Emacs from Cygwin console
  • Questioner

    When I run Emacs from the Cygwin console I get the following error message:

    bash: /usr/bin/emacs/ :Permission denied

    I have not changed any settings. I tried to change the autosave settings in the Emacs system file but that didn't work so I deleted it and saved the file.

    It was after that that I started getting this error.

    Any idea as to why this is?


  • Related Answers
  • Devon

    You probably want to go ahead and run chmod +x /usr/bin/emacs This will allow the owner, members of the same group, and everyone else be able to execute the application.

    The permission may be set to rw-r-r or something like that.