windows 7 - SD Card reader not working on Sony Vaio

24
2014-04
  • TessellatingHeckler

    This laptop (Sony Vaio VGN-Z31MN/B PCG-6z2m) has been installed with Windows 7 64 bit, all the drivers from Sony's VAIO site are installed, and everything in Device Manager both (a) has a driver and (b) shows as working, no exclamation marks or warnings.

    "Hide empty drives" in Folder options is disabled so the card reader appears, but will not read the card ("please insert a disk in drive O:").

    Previously, when the laptop had Windows XP on it, it could read the same card.

    Also, Windows update suggested driver ("SD Card Reader") doesn't work, Ricoh own drivers install properly but do the same behaviour. Other 3rd party driver suggestions from forums (Acer and Texas-Instruments FlashMedia) do not seem to install properly.

    I would post the PCI id if I had it, but it was just showing up as rimsptsk\diskricohmemorystickstorage (while it had the Ricoh Driver installed).

    Edit: If there are any lower level diagnostic utlities which might shed more light on it I'd welcome hearing of them. Anything which might show get it to put troubleshooting logs in the event log or identify chipsets or whatever...

    Update: Device details are:

    SD\VID_03&OID_5344&PID_SD04G&REV_8.0\5&4617BC3&0&0          : SD Memory Card
    PCI\VEN_8086&DEV_2934&SUBSYS_9025104D&REV_03\3&21436425&0&E8: Intel(R) ICH9 Family USB Universal Host Controller - 2934
    PCI\VEN_1180&DEV_0476&SUBSYS_9025104D&REV_BA\4&1BD7BFCD&0&20F0: Ricoh R/RL/5C476(II) or Compatible CardBus Controller
    RIMSPTSK\DISK&VEN_RICOH&PROD_MEMORYSTICKSTORAGE&REV_1.00\MS0001: SD Storage Card
    PCI\VEN_1180&DEV_0592&SUBSYS_9025104D&REV_11\4&1BD7BFCD&0&24F0: Ricoh Memory Stick Host Controller
    WPDBUSENUMROOT\UMB\2&37C186B&1&STORAGE#VOLUME#_??_RIMSPTSK#DISK&VEN_RICOH&PROD_MEMORYSTICKSTORAGE&REV_1.00#MS0001#: O:\
    STORAGE\VOLUME\{C82A81B8-5A4F-11E0-AACC-806E6F6E6963}#0000000000100000: Generic volume
    PCI\VEN_1180&DEV_0822&SUBSYS_9025104D&REV_21\4&1BD7BFCD&0&22F0: SDA Standard Compliant SD Host Controller
    ROOT\LEGACY_FVEVOL\0000                                     : Bitlocker Drive Encryption Filter Driver
    PCI\VEN_1180&DEV_0832&SUBSYS_9025104D&REV_04\4&1BD7BFCD&0&21F0: Ricoh 1394 OHCI Compliant Host Controller
    

    Now going to search for drivers for that.

  • Answers
  • Synetech

    Try updating the drivers; for my VAIO VGN-NR21E/S (Windows 7) it worked perfectly.

  • Griff

    I spent hours on this earlier today, deleted, reloaded, updated EVERYTHING!

    Device Manager always showed the reader and all devices as good.

    In the end it was simply a matter of leaving the SD card in the slot while booting.

    If the card is in the slot, it hot swaps and works beautifully.

    Without it in the slot, it simply will not read a card.

    So in short, I just leave an old 16MB card in the slot and swap it with my other cards when needed.

    My best guess is some sort of compatibility issue with that particular ricoh reader and Win7, hopefully it'll be addressed in the future, but this trick did work for me.

  • w7pro

    I'm guessing the SD reader is built in, have you tried to run the model of the SD reading in Windows 7 Compatibility Center? http://www.microsoft.com/windows/compatibility/windows-7/en-us/default.aspx

    I had a USB SD reader that worked in Vista, but for some reason wasn't compatible with Windows 7, so it's worth a try.


  • Related Question

    windows 7 - Card reader driver not installing correctly, but same driver used to work
  • AndrejaKo

    I have an Acer Aspire 7720G-813G32Bn laptop. It has integrated (maybe 3?)-in-one memory card reader. The reader uses Ricoh chip from R5C8 series. I don't know the exact model number. I can't see the chip itself because it's covered by plastic and is very difficult to remove.

    My problem are drivers. Acer has some drivers (unfortunately, driver I used, the "CarReader_Ricoh_352.02_Vistax64" is unavailable at this time, but there is still 351 version) for Vista SP1 64 bit. So far I've used those. However since the last reinstall of Windows, when I install those drivers, nothing happens. Normally, Windows would detect a bunch of unknown devices and the SD card reader. Once I install drivers from Acer, those unknown devices turn into various card readers.

    Now, however, Windows only detected SD card reader and installed the SDA Standard Compliant Host Controller. The card reader would work sporadically with that driver. After some time it stopped working altogether. At first I thought it was a hardware problem and thought is was unsolvable. Later I was trying to force the installation of Acer's drivers but when I select the .inf files, I get the "The folder you selected doesn't contain a compatible driver blah blah blah make sure driver is for win64 blah blah" error. When I try to right-lick install the .inf files, I get the "The INF file you selected does not support this method of installation" error. It worked several months ago, but doesn't now.

    While looking among available drivers in windows, I found Ricoh Secure Digital host controller R5C841 driver which I installed. Now SD card reader seems to work, but won't read SDHC cards.

    Any ideas what to do to solve this problem?

    EDIT1 I just downloaded some drivers from Microsoft(warinig: IE-only link!). With them too, I get the "The INF file you selected does not support this method of installation." error. This is strange since those drivers are from M$'s official driver website.

    EDIT2
    Here are the screenshots:

    expanded list of devices in device manager part 1 with affected devices highlighted expanded list of devices in device manager part 2 with affected devices highlighted expanded list of devices in device manager part 3 Hardware ID page for affected device

    The unknown device is CIR receiver which I do not use and which has problematic driver


  • Related Answers
  • harrymc

    I have managed to find a newer device driver than the one from Microsoft, which also supposedly supports 64-bit:
    Asus N51Vg Notebook RICOH R5C8xx Card Reader Driver 3.57.01 (Vista)

    Another and somewhat older driver is here :
    Asus X58L Notebook RICOH R5C843 Card Reader Driver

    However, for obvious reasons, I cannot test them.

  • William Hilsum

    To me, it looks like everything is working as it should from that picture. However, if you want an updated driver, take a look at Dell's support site here. Ricoh use a generic driver architecture (similar to Nvidia) and anything is pretty much compatible with anything.

    If it doesn't however, I can tell you that the way I have seen most card readers work is that they are usually one of two sorts.

    1. List as generic card reader or as a disconnected device that does not do anything, then as you put in a card of a different type, it simply activates / shows an entry in device manager....
    2. List each device which is the other behaviour I have seen, which makes me think nothing is technically wrong. (such as yours)

    so, all I can really suggest is look up the original specifications of your laptop and make sure it is compatible with the type of card you are using. If the card is not working, make sure it is in correctly.

    I have been caught out by Micro SD cards that need to be pushed in a tiny bit further etc.