Ubuntu 13.04's root password is invalid

23
2014-04
  • user2057574

    I had Ubuntu 12.04 installed with WUBI on my Windows 7. I'm using Ubuntu this way for more than a year, and pretty satisfied. I recently re-installed Ubuntu using the same wubi installer with wubi.exe --32 bit. As usual, I chose a username and a confirmed password, same as what I had in my previous installation. First I would like to mention I wanted to install Ubuntu 12.04 (therefore I used 12.04 wubi installer), but for some reason version 13.04 was installed instead. Now, when I try to login, it seems that in 13.04 one needs to enter the username in addition to the password. Oh well. But when I'm entering the credentials I chose using the wubi installer, I'm getting an "invalid password" error. Trying to use the same password with the username "root" leads to same result. If I log in through guest session and try to perform some su command and enter the password by itself, again, I'm getting an "invalid password" for root user. Is there anything I'm doing wrong? Is there any default password for root which I don't know of or something? Help, I need my linux back! Please do not recommend on a regular installation, I like it this way, and don't like the idea of partitioning. Also, note that I have uninstalled and re-installed Ubuntu 13.04 in the same way just to make sure that I'm entering my password with no capslock-on-whatever; same result.

  • Answers
    Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

    Related Question

    su command in ubuntu installed in wubi didn't work
  • Vina

    I am new linux user especially on Ubuntu. I've installed Ubuntu Lucid Lynx using in Windows XP using Wubi. When I'm trying install java, it require su command, the instruction on java said I have to put my administrator password on it. Everytime I tried my password, it wont work. Then I realized my account is not an administrator, so I change it to Administrator, but still doesnt work. Any help?


  • Related Answers
  • grawity

    do you mean su comand, or sudo command ? - the sudo command needs the password of the normal user, and su needs the root password. By default in ubuntu the root account has no password and you get to it by "becoming root" via sudo.

    try sudo -i give it your normal password, then do passwd root and you should be able to set a password for the root user. Then you can run su as a normal user to change user to root.

    normal user -> sudo -> (user password) -> root for one command normal user -> su -> (root password) -> root until exit given.

    sudo has configuration to say who can run which commands as root, but by default the user you created at install can do what you need.

    does that help / make sense ?

    In the long run though, in this particular instance you'd be better off doing sudo -i to get root on a temporary basis, and run the installer from there (i.e: as root).

  • Neal

    On Ubuntu, you are "supposed" not to need to use the "su" command. Rather than use "su" to get root priviledges until you use the "exit" command, you are supposed to preceed each command with the "sudo" command.

    So

    $ su

    # command1

    # command2

    # command3

    # command4

    # exit

    $

    becomes

    $ sudo command1

    $ sudo command2

    $ sudo command3

    $ sudo command4

    $

    (Note that the prompt changes from "$" to "#" to show that you are root.)

    As an alternative, you can use the command "sudo su -" rather than "su" to become root in Ubuntu.

  • IanH

    Use sudo su and enter your user password when asked for it.