Why doesn't my belkin usb 2.0 4-port ultra-mini hub work on windows xp?

18
2014-04
  • dfrankow

    I just bought a belkin usb hub. I am running a fully updated Windows XP. When I plug in the device, it is not recognized. The device manager says "Unknown Device". The device properties say "There is no driver installed for this device." If I remove the device from the device manager listing and "scan for new hardware" I get back to the same state.

    Edit: Its red light is on, so it is getting power.

    Why is it not working, and how do I fix it?

  • Answers
  • George

    Try this:

    1. Belkin's support page to see if there is something you are missing for that USB hub.
    2. Also try to reboot your PC/laptop, but keep the hub plugged in.
    3. Double check your chipset driver and update it if you need to, along side with any other drivers the PC/laptop manufacturer.

    Good luck!

  • Ankh2054

    Try uninstall your USB root hubs in your XP device manager. After uninstall reboot the PC and try again. The drivers should automitically re-install.

    If that does not work, it might be the actual USB port on the PC, not all USB ports actually support USB hubs. Usually the USB ports on the back of teh machine supports USB hubs.

    You can also try and see if the manufacturer of your PC/laptop has any


  • Related Question

    Why are my USB 2.0 devices hanging Windows XP?
  • BenAlabaster

    Background on the machine I'm having a problem with:

    The machine was inherited and appears to be circa 2003 (there's a date stamp on the power supply which leads me to this conclusion). I've got it set up as a Skype terminal for my 2 year old to keep in touch with her grandparents and other members of the family - which everyone loves.

    It has a DFI CM33-TL/G ATX (identified using SiSoft Sandra) motherboard hosting an Intel Celeron 1.3GHz CPU, 768Mb PC133 SDRAM, a D-LINK WDA-2320 54G Wi-Fi network card and a generic USB 2.0 expansion board based on the NEC uPD720102 chipset containing 3 external and 1 internal USB sockets. It's also hosting a 1.44Mb floppy drive on FDD0, a new 80Gb Western Digital hard drive running as master on IDE0 and a Panasonic DVD+/-RW running as master on IDE1.

    All this is sitting in a slimline case running off a Macron Power MPT-135 135W Flex power supply.

    The motherboard is running a version of Award BIOS 05/24/2002-601T-686B-6A6LID4AC-00. Could this be updated? If so, from where? I've raked through the manufacturer's website but can't find any hint of downloads for either drivers or BIOS updates.

    The hard disk is freshly formatted and built with Windows XP Professional/Service Pack 3 and is up to date with all current patches. In addition to Windows XP, the only other software it's running is Skype 4.1 (4.2 hangs the whole machine as soon as it starts up, requiring a hard boot to recover).

    It's got a Daytek MV150 15" touch screen hooked up to the on board VGA and COM1 sockets with the most current drivers from the Daytek website and the most current version of ELO-Touchsystems drivers for the touch component.

    The webcam is a Logitech Webcam C200 with the latest drivers from the Logitech website.

    The problem:

    If I hook any devices to the USB 2.0 sockets, it hangs the whole machine and I have to hard boot it to get it back up. If I have any devices attached to the USB 2.0 sockets when I boot up, it hangs before Windows gets to the login prompt and I have to hard boot it to recover.

    Workarounds found:

    I can plug the same devices into the on board USB 1.0 sockets and everything works fine, albeit at reduced performance. I've tried 3 different kinds of USB thumb drives, 3 different makes/models of webcams and my iPhone all with the same effect. They're recognized and don't hang the machine when I hook them to the USB 1.0 but if I hook them to the USB 2.0 ports, the machine hangs within a couple of seconds of recognizing the devices were connected.

    Attempted solutions:

    I've seen suggestions that this could be a power problem - that the PSU just doesn't have the wattage to drive these ports. While I'm doubtful this is the problem [after all the motherboard has the same standard connector regardless of the PSU wattage], I tried disabling all the on board devices that I'm not using - on board LAN, the second COM port, the AGP connector etc. through the BIOS in what I'm sure is a futile attempt to reduce the power consumption... I also modified the ACPI and power management settings. It didn't have any noticeable affect, although it didn't do any harm either. Could the wattage of the PSU really cause this problem? If it can, is there anything I need to be aware of when replacing it or do I just need to make sure it's got a higher wattage than the current one? My interpretation was that the wattage only affected the number of drives you could hook up to the power connectors, is that right?

    I've installed the USB card in another machine and it works without issue, so it's not a problem with the USB card itself, and Windows says the card is installed and working correctly... right up until I connect a device to it.

    The only thing I haven't done which I only just thought of while writing this essay is trying the USB 2.0 card in a different PCI slot, or re-ordering the wi-fi and USB cards in the slots... although I'm not sure if this will make any difference - does anyone have any experience that would suggest this might work?

    Other thoughts/questions:

    Perhaps this is an incompatibility between the USB 2.0 card and the BIOS, would re-flashing the BIOS with a newer version help? Do I need to be able to identify the manufacturer of the motherboard in order to be able to find a BIOS edition specific for this motherboard or will any version of Award BIOS function in its place?

    Question:

    Does anyone have any ideas that could help me get my USB 2.0 devices hooked up to this machine?


  • Related Answers
  • mauvedeity

    I had all manner of problems on an older machine trying to use my iPod over USB through a cheap USB 2.0 PCI card I had. In the end, I chucked it and bought a more expensive one, and all the problems went away. I'd suggest trying that. I can't imagine that a USB 2.0 PCI card will cost much these days, but do what I did and buy the next one up from the cheapest one you can get.

  • quack quixote

    VT8601 sounds like a VIA chipset to me. (Indeed, Google gives this PLE133 chipset spec page as the top link; seems the VT8601 is the northbridge for the PLE133, a Pentium-III era chipset.)

    What's the chipset on the USB expansion board? I've been generally dissatisfied with VIA chipsets in general, so I try to avoid them when possible, but the last time I bought a PCI USB-2 controller, I don't think I ever found a non-VIA card. I ended up with a card that identifies itself as a "VT82xxxxx" under Linux's lspci command; it works fine under Linux in a Pentium-II era Intel motherboard.

    I'd presume your BIOS is likely the latest available, but it's possible you might find another one out there somewhere. If you haven't checked the underside of the motherboard for identification, do so; it will help your search immensely to know the motherboard manufacturer.

    Other things to try:

    • Strip the current system of everything not necessary (like the WiFi card) and try the USB-2 card that way. Disable the on-board USB. If it's a power issue, removing the WiFi may allow it to work -- in which case you can simply replace the PSU.
    • Hook up an optical drive, disconnect the hard drive, and boot a Linux LiveCD, and see if Linux has the same problem. (Ubuntu should work, but Xubuntu may be more responsive on your system.)

    If you can, post the USB card's chipset; that may help tease out known incompatibilities or other potential solutions.