networking - Windows 7 can't reconnect network drives on startup

20
2014-04
  • Znarkus

    I have this annoying problem that Windows 7 won't reconnect to my network drives on startup. The shares are on an Ubuntu machine.

    could not reconnect

    I've tried every possible solution I've found:

    • Enable password on logon to give the network interface time to boot up
    • Check Connect using different credentials

      map network drive

    • Tried both options in this screen

      password

    Sorry for the long post. Can You please help me to solve this?

  • Answers
  • Puddingfox

    Try connecting to the share by hostname, not IP address. In my experience, Windows never liked remembering passwords for IP addresses. Also, it's unlikely this is the cause since it looks like this is a home installation, but there are group policy settings to prevent passwords from being remembered.

  • Znarkus

    What ultimately worked, was setting the same credentials on server and client. Then Windows didn't have to remember anything, just login with my standard login credentials.


  • Related Question

    windows 7 - Domain-member Win7 system can't access Ubuntu share
  • Scott Smith

    I have a home network with the following computers:

    • Windows XP SP3 (workgroup: MSHOME)
    • Ubuntu 10.04 LTS (Samba, workgroup: MSHOME)
    • Windows 7 Ultimate company laptop (domain: XYZ)

    XP <--> Ubuntu works fine

    Both XP and Ubuntu are on the same workgroup, and they can access each other's shares just fine.

    Win 7 <--> XP works fine

    My Win 7 work laptop (member of a domain) can also access shares on the XP box (using credentials <hostname>\<username> and <password>), even though the laptop is not a member of the MSHOME workgroup.

    Win 7 <--> Ubuntu ... not so much

    For some reason, I can't access shares on the Ubuntu box from my laptop. I can see the shares if I type \\<hostname>\ into Win7 Explorer. However, clicking on a displayed share in Explorer produces a credentials prompt, and no matter what I enter, I get a permission denied message.

    Interestingly, I get a slightly different error message if I type in an intentionally incorrect password, so I believe things are working up to a point...

    The Samba Server Configuration app in Ubuntu has some different Authentication Mode settings. The default is User, and I haven't changed it.

    Has anyone dealt with this configuration (Win7-domain / Samba-workgroup)?

    Any help would be greatly appreciated. I've been searching online and trying various things, but no joy. I don't know how to see what's actually happening behind the scenes, so it's just down to trying every combination I can think of until it works...


  • Related Answers
  • Cry Havok

    I suspect the Windows 7 laptop is automatically adding domain XYZ to the username. Have you checked the logs on the Samba server to see what it's reporting?