Windows 7 doesn't recognize USB devices anymore

18
2014-04
  • NeedACar

    So I have a problem with my desktop. I have an iPad 2 which WAS working fine on my desktop, however, after a week of not connecting it, it suddenly isnt recognized anymore by windows 7. First I thought it was an Apple issue, but then I disconnected my External hard drive, to find that when reconnecting it again it didnt work anymore with the same problem. I'm afraid to pull out any other USB devices since they may stop working....

    I have done so far: - Rebooted - Reinstalled usb drivers - Have had power off the motherboard/pc for a while. - Updated windows/drivers.

    Any ideas? thx

  • Answers
  • Karan

    Things I've tried in the past in similar situations that worked:

    1. Run USB Oblivion with the Do real clean checkbox checked, then rebooted:

      1

    2. Deleted all USB root hubs and controllers from Device Manager, then rebooted. This is best done with a PS/2 mouse/keyboard connected, since obviously USB devices will stop working.

    3. Completely unplugged PC and removed the CMOS battery. Inserted battery after 10-15 mins., powered on, set BIOS options (that have all reverted to defaults) as required, then booted into Windows.

  • Andy

    USBDeview will give you a view of what is going on.

    "USBDeview is a small utility that lists all USB devices that are currently connected to your computer, as well as all USB devices that you previously used. For each USB device, extended information is displayed: Device name/description, device type, serial number (for mass storage devices), the date/time that device was added, VendorID, ProductID, and more...USBDeview also allows you to uninstall USB devices that you previously used, disconnect USB devices that are currently connected to your computer, as well as to disable and enable USB devices. You can also use USBDeview on a remote computer, as long as you login to that computer with admin user."

  • NeedACar

    Update on my problem, I didnt solve the USB problem but my guess was that it was a hardware issue since I basically ruled out all software issues. However, last week, my PC stopped working completely so maybe the USB problem was just the start of the end, and since I was planning in getting some new hardware anyway...thats what I will do.


  • Related Question

    "USB Device Not Recognized" from USB Storage devices
  • Sticky

    Usually when USB devices are plugged in, they will be successfully recognised and installed. Unfortunately, there are those occasions when my wonderfully-archaic computer decides that it doesn't want all these USB devices, and so will simply render all USB storage devices inoperable.

    It does this by suddenly forcing them to be "unrecognised"; often leading to data loss and MFT corruption. Other USB devices, such as my headset or USB mouse are unaffected. I have found that I can usually trigger this problem by having at least four devices plugged in - typically mouse, ext. HDD, headset, and then once a flash drive is plugged in both the flash drive and the ext. HDD become unrecognised.

    The only possible way I've found of fixing this problem is to load Device Manager using

    set DEVMGR_SHOW_DETAILS=1
    set DEVMGR_SHOW_NONPRESENT_DEVICES=1
    start devmgmt.msc
    

    setting it to show hidden devices, uninstalling all USB drivers for all previously installed devices and hubs, shutting the computer down, and then unplugging it from the wall overnight. This becomes a very time consuming process for an issue that you would think would be something easy to fix.

    I still have free USB ports when the issue occurs, but the fact that it requires leaving the computer unplugged overnight to fix suggests to me that it may be an issue with the BIOS or motherboard itself. How this happens though, I have no idea.

    Any suggestions or thoughts to prevent this or alternative suggestions to fix the problem that take less time would be much appreciated.


  • Related Answers
  • harrymc

    Are these USB devices self-powered?

    If not, it might be that the power-supply is not up to the task of supporting them. As you mention that this is an old computer, I hope that the power-supply is not getting weaker in its dotage.