Windows 8 - Mapping Network Drive (NAS)

19
2014-04
  • Dusty Roberts

    This question has been asked throughout the web, but I am simply not able to get it working.

    I am Running Windows 8 Pro (x64), when I connect to the office network, I can connect to all network shares except the ones that is on our (NAS).

    As soon as I boot into Windows 7, I am able to connect.

    So far I have tried the following:

    1. http://support.microsoft.com/kb/2686098
    2. http://help.unc.edu/help/connecting-to-nas-with-windows-8/
    3. http://social.technet.microsoft.com/Forums/en/w7itpronetworking/thread/c1d2e480-65e8-41ad-b7a4-73d4ba3ca09d
    4. Windows 8 Pro NAS not recognized? (tried all suggestions)

    All of the above with no success.

    I also tried the net use command, to see if it might return additional info, but i get Error 53

    net use k: \\omsmds001\
    System error 53 has occurred.
    The network path was not found.
    

    and

    net use k: \\10.0.25.3
    System error 53 has occurred.
    The network path was not found.
    

    When i ping the device i get no response

    When i try and browse the network location, i get an error:

    Windows Cannot access \\omsmds001
    Error Code: 0x80070035
    The network path was not found
    

    I have disabled "SecureNegotiate" and i can't enable SMB on the device, it is out of my control.

    UPDATE I have had some luck here: I connected to a server that is on the domain, i pinged the server again and received a different IP address. I used that IP address and i am now able to map the disk with the IP. using host name still fails in windows 8.

  • Answers
  • John Siu
    1. IP address

      Check Windows 7 and Windows 8 are using same subnet and gateway. Use following command

      ipconfig
      

      If Windows 7 can ping the device, Windows 8 should be able to also.

    2. Turn off firewall

      In file explorer, go to following and turn off firewall

      Control Panel\All Control Panel Items\Windows Firewall
      

      If you have other firewall software like norton360, you will have to disable it within those software.

    3. Check file sharing is enable

      In file explorer, go to following

      Control Panel\All Control Panel Items\Network and Sharing Center\Advanced sharing settings
      

      Under section All Networks, check File sharing connections, select Enable file sharing for devices that use 40- or 56-bit encryption

    4. Check remembered credentials

      In file explorer, go to

      Control Panel\All Control Panel Items\Credential Manager
      

      Click Windows Credentials. Check if there are credential related to that NAS, delete it.

    5. WiFi and Wired

      If you have both w-fi and cable connection, try turn off wi-fi.

  • Stefan Seidel

    As I understand it, you need to map a share on a NAS, you cannot map the NAS itself. So try

    net use k: \\omsmds001\nameOfTheSharedFolder
    

    Whether or not your share works with the name (as opposed to the IP address) could depend on various factors, such as

    • your DNS setup - does the configured DNS server know about the NAS's name?
    • the WINS setup - is there a WINS server in your network
    • the Windows Domain setup - are you part of a domain, does the domain controller know the NAS name, does the NAS know your domain controller and is part of the domain
  • davefromcamp

    SO my NAS by dlink couldn't be seen wither and Synology help was of no help either. I tried uninstalling my LAN driver, re-installing it, trying every thing on this forum:

    http://forum.synology.com/enu/viewtopic.php?f=49&t=60999&p=250609#p250609

    Also enabled SNMP under components/enable windows features

    What I think finally helped was this:

    Go to System in Win 8. This is really easy on the metro screen type system then in settings its right there. (this screen has your Windows Experience rating)

    Under Computer name, domain, and work group settings to the right it says change settings. Clink this.

    Under Network ID it will have 2 bubble options: This computer is part of a business netowork or part of a home computer. I chose HOME COMPUTER option. Restarted and problem solved. Good luck!

  • Jawa

    Same problem for me, Win7 machines could see the NAS drive and shares, Win8 64 Pro could not.

    If you can connect to the NAS via IP (e.g. \\\192.168.0.4 ) try adding an entry to the hosts file - it worked for me.

    C:\Windows\System32\Drivers\etc\hosts  
    

    Add a line with the fixed IP address and device name, e.g.

    192.168.0.4 NAS
    

    now use file explorer to navigate to \\\NAS.

  • slhck

    The fix is easy:

    • Find your way to the registry entry HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters\RequireSecuritySignature

    • Set the parameter to 0

    Microsoft acknowledges this issue and has two workarounds: "System error 2148073478," "extended error," or "Invalid Signature" error on SMB connections in Windows 8 or Windows Server 2012

  • klyonrad

    I had the same problem after recently installing windows 8, and after trying several more or less complicated solutions, what fixed it was the same as davefromcamp's solution (I'm not allowed to upvote yet, but I wanted to share that this worked for me as well, and that it was a really simple solution)!

    What made the trick was:

    1. Open up "System" from the Control Panel. One way to access the control panel is to hover the mouse in the right upper or lower corner, slide the cursor to Settings, click, and then select Control Panel from the list. Click "System and Security" and then "System".
    2. Under "Computer name, domain, and workgroup settings" click the "Change settings" link, located at the right next to an administrator shield icon.
    3. On the first tab "Computer name", click the button that says "Network ID..." This opens up a window with only two choices.
    4. Select "This is a home computer; it's not part of a business network". Click finish and let windows restart itself.

    Hope this can help more people with the same problem!


  • Related Question

    networking - Vista cannot map network drive
  • andreas

    As per subject, I'm not able to map a remote network drive to my Vista. I tested on an XP machine in the same network as mine and it's able to map the said drive, I also tried another Vista in the same network, but it's not able to map as well. So it's definitely the Vista.

    Anyone can shed a light on this?

    EDIT: The error message was just generic Windows cannot access \\xx.xx.xx.xx\share_name

    EDIT2: Ok, after the error message appears, it actually asks me whether I want to diagnose. So I did and I got this:

    [Window Title] Windows Network Diagnostics

    [Main Instruction] "xx.xx.xx.xx" is not set up to establish a connection on port "File and printer sharing (SMB)" with this computer.

    [Windows found a problem that cannot be repaired automatically] [Cancel]


  • Related Answers
  • pete

    Probably has to do with LAN Manager authentication level.

    If you have the full featured Vista (access to security policy gui) follow this http://www.builderau.com.au/blogs/codemonkeybusiness/viewblogpost.htm?p=339270746

    Otherwise you'll have to change the value in the registry HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\LMCompatibilityLevel from a 3 to a 1

    This applies to Win7 machines too when trying to browse XP / Samba shares.

  • John

    Make sure the workstation service is started and set for automatice startup. This is needed to access network shares.