copy - Windows 8 Permissons: Copying a File, Access Denied, Despite Take Ownership

23
2014-04
  • ChrisJF

    I just wiped my hard drive with Windows 7 and did a fresh install of Windows 8. I backed up my files on an external hard drive. When I tired copying my music over to Windows 8, I got this message for about two albums worth of songs:

    Provide permission error

    So I click "Continue" and then I got this message:

    Need permission from user

    (I blacked out my computer name and email address in the screenshots for privacy reasons.)

    At first, it said I needed permission from my old Windows 7 user account. So I searched online and all the tutorials told me that I needed to "Take Ownership" of the file so I could copy it.

    I used this Microsoft Support tutorial which is for Windows XP, but the process is generally the same for Windows 8. http://support.microsoft.com/kb/308421

    And when I'm finished the "Advanced" window in the file's Security Properties looks like this:

    Owner with Full Permissions

    I made my user the Owner, AND I made my user have "Full" permissions (when you highlight my username in the "Permissions" box, click the "Edit" button and then check the "Full Control" option.) (Also, while trying to get this working, I deleted the "SYSTEM" user permissions, and the "Everyone" user permissions, just by some crazy off-chance that might work. No luck.)

    What am I doing wrong here? The Properties window says I'm the owner and have permission, but when I copy, it still gives me the "File Access Denied" error, just like before! Any help would be greatly appreciated. Thank you in advance!

  • Answers
  • fefrei

    To access a file, you need to have read access, not have a "deny" flag for read access set, have the key if the file is encrypted, and the file must not be locked for exclusive use.

    So, I'd recommend to...

    • Disable inheritance on the folder to make sure you don't inherit a "deny"-Flag
    • check Effective access to see which permissions you really have
    • check Properties -> Advanced to see if the file / folder is encrypted
    • reboot to make sure no application is locking the file / folder
  • ChrisJF

    So this isn't really the answer I was looking for, but anyway...

    What I ended up doing was copying the whole folder over again. I realized Windows 8 was just choking on about two folders (two albums of music) with the rest of the 15GB copying just fine. I copied what I could, then I plugged my iPod into my computer and pulled the two folders of music manually from there and just placed the files where they normally should have copied. So I guess the lesson of the day is: backup, and then make another backup!

  • Bill Keene

    i opened "computer", then clicked on C:, then right clicked on C:, select Properties, go to permissions, users, select Full Control, click apply, this will change permissions for C: and all folders, sub-folders, and files on C: (the hard drive). Good Luck.


  • Related Question

    windows 7 - can't access/delete or retake ownership of previous MyPictures folder (win7)
  • Raoul Duke

    I have a directory called pics which was configured as My Pictures folder, now I changed the location to another directory but I can't remove the old pics folder. When I go to the security properties it says Unable to display current owner and I can't take ownership, neither through that security dialog nor through takeown. I've also tried to change the ACLs using cacls but all those result in the same access denied message. I'd appreciate any hint.

    thanks,

    Raoul


  • Related Answers
  • Raoul Duke

    Seems there's no other way than to boot into safe mode to do it. That worked at least. Typical Microsoft bullcrap.